OpenGarage Forums OpenGarage Firmware Sensor readings stop updating

This topic contains 2 replies, has 2 voices, and was last updated by  2Crazy4Nick 2 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1421

    2Crazy4Nick
    Participant

    I’ve recently set up a nodemcu v2 with a HC-SR04 proximity sensor and a DHT11 T/H sensor in my garage using OG v1.1.0.

    When booting everything works like a charm – timings, thresholds, accessing via Blynk and even automating it with IFTTT or Stringify. If not for the problem that the sensors keep updating for some time (I can watch the read count in the webinterface go up and loop around after 99) and suddenly stop updating around roughly an hour after the last reboot. The nodemcu itself is still responsive and can be accessed any way – but the sensors (proximity + H/T) stop updating in web and Blynk as well.

    I’ve considered adding an automated device reboot every so often to keep the sensor updating but that’s hardly a real solution.

    So I’m hoping to find some advice here on what might be the problem or least if somebody else experienced something similar. The situation to me sounds more like a firmware problem, I’ve tried reflashing it so far without any changes in behavior.

    #1424

    Ray
    Keymaster

    You said “set up a nodemcu v2 with a HC-SR04 proximity sensor and a DHT11 T/H sensor in my garage using OG v1.1.0.” — so I assume this is using your own hardware and not purchased from us? Also, did you modify the firmware yourself? The stock firmware does not send T/H readings to Blynk, and you said it stopped updating Blynk. If you modified the firmware yourself you can turn on debugging by uncommenting the #define SERIAL_DEBUG line in defines.h

    #1425

    2Crazy4Nick
    Participant

    Hey Ray,

    Thanks for getting back at me. As I’m quite an impulsive person that needs to do stuff the moment they get an idea before losing interest the delivery time to Germany wasn’t really gonna cut it. I also really like to tinker around, even though computer science at university wasn’t really my thing.

    I really appreciate you taking the time to try and help me out – I’m not that confident in coding so I was really glad I found something as neat as OpenGarage.

    Anyway: I didn’t modify really modify the firmware, I tried adding in the T/H to Blynk, I guess I would have to define another V# in the defines.h and fiddling around with the main.cpp? But right now I actually don’t have that sensor in Blynk – sorry for being unclear here. I only compiled the source for v1.1.0 from GitHub in Arduino and have it currently flashed “vanilla”. The ultrasonic sensor is the one showing and it doesn’t update on either side. T/H did not update as well (only shown on the web UI), when I tried holding it in my hand to raise the temperature.

    In the meantime I’ve tried to pinpoint the time until the readings stop updating and it seems to be pretty exactly half an hour actually.

    I will try uncommenting the debug and reflash, that should give me at least some ideas what might be wrong. I’ll make sure to post the debug log here as well, nothing worse then somebody searching for a problem they have only to find the one guy that had it as well never posted the solution. But that’ll have to wait until tomorrow, 1 am already over here..

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

OpenGarage Forums OpenGarage Firmware Sensor readings stop updating