OpenGarage Forums OpenGarage Firmware Sensor readings stop updating Reply To: Sensor readings stop updating



Hey Ray,

Thanks for getting back at me. As I’m quite an impulsive person that needs to do stuff the moment they get an idea before losing interest the delivery time to Germany wasn’t really gonna cut it. I also really like to tinker around, even though computer science at university wasn’t really my thing.

I really appreciate you taking the time to try and help me out – I’m not that confident in coding so I was really glad I found something as neat as OpenGarage.

Anyway: I didn’t modify really modify the firmware, I tried adding in the T/H to Blynk, I guess I would have to define another V# in the defines.h and fiddling around with the main.cpp? But right now I actually don’t have that sensor in Blynk – sorry for being unclear here. I only compiled the source for v1.1.0 from GitHub in Arduino and have it currently flashed “vanilla”. The ultrasonic sensor is the one showing and it doesn’t update on either side. T/H did not update as well (only shown on the web UI), when I tried holding it in my hand to raise the temperature.

In the meantime I’ve tried to pinpoint the time until the readings stop updating and it seems to be pretty exactly half an hour actually.

I will try uncommenting the debug and reflash, that should give me at least some ideas what might be wrong. I’ll make sure to post the debug log here as well, nothing worse then somebody searching for a problem they have only to find the one guy that had it as well never posted the solution. But that’ll have to wait until tomorrow, 1 am already over here..