OpenGarage Forums OpenGarage Firmware Fork with MQTT, Magnetic Sensor support ,Close if left open at night – misc

This topic contains 81 replies, has 7 voices, and was last updated by  andyss 1 year, 4 months ago.

Viewing 15 posts - 61 through 75 (of 82 total)
  • Author
    Posts
  • #739

    italoc
    Participant

    @lawrence_jeff

    my opengarage is still locked in customs

    I’m angry with my postal service, they tell me it may take 1 week or 10 days

    #740

    sirotkaslo
    Participant

    I received magnetic switches today, will give it a try tomorrow and post pics.

    #741

    lawrence_jeff
    Participant

    Sounds great.. post if you have any issues with it.

    #742

    italoc
    Participant

    @lawrence_jeff

    i have received my official opengarage just now, now i update your firmware and during this weekend i mount the magnatic sensor…

    #745

    italoc
    Participant

    Hi lawrence_jeff,

    Magnetic contact works very well with your firmware, let me know if you need more images

    Tomorrow I con mount OpenGarage and magnetic contact on my external gate…

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #749

    lawrence_jeff
    Participant

    Great to hear it is working for you- let me know if you see anything with this config you think should be changed, one thing I notice is that I should hide the fake distance. Basically to maintain compat with all the built in code I just set the distance to either a fake high or fake low number – but that shouldn’t be displayed on the homepage

    Also is your OG Unit able to see your vehicle with the distance sensor? I was planning on making it so the firmware had a mode where the built in sensor can be used exclusively for determining if you have a vehicle present and the door sensor used the switch. Let me know if this is of interest (I couldn’t remember if you said you were going to be mounting outside)

    #751

    sirotkaslo
    Participant

    All working great here! I would love for a mod where you could use the distance sensor for vehicle detection and the magnetic one for the door.

    #752

    italoc
    Participant

    Also is your OG Unit able to see your vehicle with the distance sensor? I was planning on making it so the firmware had a mode where the built in sensor can be used exclusively for determining if you have a vehicle present and the door sensor used the switch. Let me know if this is of interest (I couldn’t remember if you said you were going to be mounting outside)

    no my OG can see vehicle it’s connected to extarnal gate, but i have noticed a little bug in you bin image file, the image of NO VEHICLE is not found…

    #753

    lawrence_jeff
    Participant

    I didn’t understand your response, did you mean No my OG can not see vehicle, if you can’t see the vehicle you can disable detection by setting the vehicle detection threshold to 0 (which I think you probably know as your screenshots appeared to have it off)

    The extra pictures require you to manually burn an additional firmware file which can’t be done currently through the GUI – but in your case if you can’t see the vehicle I wouldn’t worry with it.

    If I misunderstood and you CAN see the vehicle let me know and I can try to make the firmware handle the scenario where the sensor can be used to detect a vehicle and the door sensor is used exclusively for the door.

    #754

    lawrence_jeff
    Participant

    All working great here! I would love for a mod where you could use the distance sensor for vehicle detection and the magnetic one for the door.

    Ok – let me take a look at just moving that scenario from dev to the prod firmware.. need to fight the urge to rewrite lots of pieces to support that.

    #755

    italoc
    Participant

    The extra pictures require you to manually burn an additional firmware file which can’t be done currently through the GUI – but in your case if you can’t see the vehicle I wouldn’t worry with it.

    i have uploaded this file Graphics-placeat00300000.bin more picture are present but not the image of NO VEHICLE

    I didn’t understand your response, did you mean No my OG can not see vehicle, if you can’t see the vehicle you can disable detection by setting the vehicle detection threshold to 0 (which I think you probably know as your screenshots appeared to have it off)

    My opengarage cant see vehicle, it’s located inside the motor of external gate and use only magnetic sensor for know the position of the gate

    #756

    sirotkaslo
    Participant

    Tested this for a few days, it’s great. Works with home assistant. Had only one fail,but that was my fault – closed the door before home assistant changed stato from opening to open.

    #757

    lawrence_jeff
    Participant

    Great to hear – I kept all the API stuff backwards compatible so it shouldn’t break anything. I did add explicit close and open commands I wonder might help with using things like home assistant. The vanilla firmware accepts only a click command so can get out of whack if something else is changing the state. Mine also supports explicitly saying you want to close or open, so if the external stuff gets confused and sends a close when OG is already closed it won’t then open like the native firmware would when receiving the click command (it sees its already closed and does nothing)

    Probably wouldn’t take much to tweak – just replace the click=1 with close=1 and open=1 in the appropriate places.

    • This reply was modified 1 year, 8 months ago by  lawrence_jeff.
    #881

    [email protected]
    Participant

    The icons are not displayed on your @lawrence_jeff firmware.

    Everything else worked great for me. Specially that the IGMPv2 reset bug is fixed.

    #882

    lawrence_jeff
    Participant

    Unfortunately you can’t get the icons via the built in update function (it doesn’t update the place where they are stored)
    If you want to use a firmware burning tool you can use the bin Graphics-placeat00300000.bin to get them on the device.

    I don’t believe I have seen mention of the IGMPv2 bug, can you provide more detail.

Viewing 15 posts - 61 through 75 (of 82 total)

You must be logged in to reply to this topic.

OpenGarage Forums OpenGarage Firmware Fork with MQTT, Magnetic Sensor support ,Close if left open at night – misc